Skip to main content

iX Developer 3.1

Projects

This section describes how to work with projects in iX Developer.

Tip

A project consists of two main sets of files:

  • Design Files: These files relate to the functional and graphical design of the project.

  • App Files: These files are compiled from the design files and are used in the iX App.

When a new project is created, a top-level folder named after the project is created, referred to as the Project folder. The files that define the functional and graphical design are stored at the top level of this folder. Additional folders are generated during validation and build processes.

Note

  • Do not save your iX project in a folder that syncs with Microsoft OneDrive, Google Drive, or similar services. This may prevent the project from opening and cause an Access Denied error.

  • Keep file and folder names short. If any file path in the project folder exceeds 260 characters, Build, Rebuild, Run or Simulate fails.

The Project Properties includes iX App behavior, system font, and settings for mouse and keyboard. To open the project properties, click Project > Settings in the Project Ribbon Tab.

Advanced

Parameter

Description

Screen Cache

Set default value on all new screens to cache

Enables the Cached option in General > Screen for all newly created screens. If unchecked, Cached is disabled by default for new screens.

Note

This does not apply to the start screen (always cached) and popup screens (never cached).

Screen cache in project

Set all to cache

Enables Cached in General > Screen for all existing screens, except the start screen and popup screens.

Remove all cache

Disables Cached in General > Screen for all existing screens, except the start screen and popup screens.

Filenames

Enable FTP friendly names

When enabled, file names with spaces are replaced with underscores, and periods (except for before the extension) are replaced with dashes.

. Applies to
Example 2. Example

File name changes from: ReportTemplateName yyyy.mm.dd hh:mm:ss.extension

to: ReportTemplateName_yyyy-mm-dd_hh-ss.extension



OPC UA Structured Tags

Enable Structured Tags

Enables OPC UA Structured Tags in the project. Disabled by default.OPC UA Structured Tags

Script Warnings Behavior

Determines how script warnings are handled during project build.

. Options
  • Ignore warnings – No warnings displayed.

  • Show warning – Warnings are shown.

  • Treat warnings as errors – Warnings are treated as errors.

Alarm Button

Parameter

Description

Show Screen

Select the screen to display when the predefined alarm key is pressed on a keyboard-operated HMI panel.

Database

Parameter

Description

Database location

Sets location for the active database.

  • Hard drive – Saves the database to the HMI panels internal flash drive.

  • SD card (default) – Saves the database to the SD card.

    Caution

    Beijer Electronics recommends storing the database and data logs on the SD card to reduce flash wear on the internal drive. For detailed information, see External Storage Media Recommendations.External Storage Media Recommendations

Database Settings

Back up database at startup

When enabled, a backup of the database is created at startup if the integrity check is successful. If the integrity check fails, the system uses the previous backup. If no backup is available and the database is corrupt, the corrupt database will be replaced with a new, empty one.

Note

Enabling this option increases the HMI panels startup time.

Max size (MB)

When the database exceeds this size, the system tag Database Max Size Exceeded is set. For more information, see Available System Tags.

Display/Target

Parameter

Description

Window

  • No Title Bar: Displays the project without title bar in the iX App. This alternative cannot be used for popup screens.

  • Title Bar: Displays the project with its title and a set of minimize, maximize and close buttons in the title bar.

  • Close Button: Displays the project with a title and a close button in the title bar.

Maximize On Startup (only for PC targets): When enabled, the app window is maximized in the iX App.

Screen Size (only for PC targets)

Defines the screen resolution for the project.

Target Rotate

Not available in the current version of iX Developer.

Target Type

Displays the selected target device. To change the project target, see Change Project Target.

Mouse/Touch Input Delay

Parameter

Description

Time (ms)

Configures the input delay for mouse and touch actions in the iX App. This delay can be applied globally to all objects that have Delay Mouse/Touch Input enabled without a specific delay, or it can be set individually for each object. To configure the delay for individual objects, use the Property Grid Window.

To reset to the delay setting, enter 0.

Project Transfer

Parameter

Description

Include source code when transferring project

When enabled, the software transfers a zipped file containing all source code to the HMI panel during App transfer.

Important

This option must be enabled to use the Fetch the Project From the HMI Panel feature later.

Set password to zip file

Protects the zipped source code file with a password.

System Requirements

This chapter describes how to define the System Requirements in iX Developer.

In iX Developer 3, you cannot configure system settings directly as in previous versions. Instead, you define System Requirements that are evaluated and then reserved by the OS3 operating system. If the requirements are not met, the iX App is installed on the HMI panel but cannot run.

Tip

  • For information on the HMI panels system settings, see App-Required System Settings in the OS3 User Guide.

  • When converting an iX Developer project from iX2 to iX3, you can manually import the system settings from iX2 to the System Requirements. For instructions, see Migrate System Settings from iX2 to iX3 in the X2 to X3 – Transition Guide.

Parameter

Description

COM port (only for HMI panel targets)

Enter the required mode for a COM port. Select Any, RS-232, RS-422, RS-485 or CAN. The number of available ports and possible configuration differ depending on selected target. For configuration instructions, refer to Serial Ports in the OS3 User Guide.

Network interface - Default gateway

Enter the required default gateway for the selected network interface.

Network interface - IP address

Enter the required IP address for the selected network interface.

Network interface - Primary DNS server

Enter the required primary DNS server for the selected network interface.

Network interface - Secondary DNS server

Enter the required secondary DNS server for the selected network interface.

Network interface - Subnet mask

Enter the required subnet mask for the selected network interface.

Power saving - Automatically turn off display

Select Yes to enable automatic backlight turn-off. This reduces backlight usage, helping extend the lifespan of HMI panels.

Power saving - Seconds until display is automatically turned off

(only available if Power saving - Automatically turn off display is set to Yes)

Select the duration after which the backlight turns off automatically.

TCP server port

Enter the required TCP server port number for incoming traffic.

Time - SNTP synchronization

Select Yes if the panel clock needs to be synchronized with an external SNTP (Simple Network Time Protocol) server.

Time - SNTP server

(only available if Time - SNTP synchronization is set to Yes)

Enter the SNTP server name for time synchronization.

Time - SNTP update interval

(only available if Time - SNTP synchronization is set to Yes)

Enter the synchronization update interval in minutes.

UDP server port

Enter the required UDP server port number.

System Dialogs

Parameter

Description

Color

Form Color

Background: Background color of system dialogs.

Foreground: Font and foreground element color.

Control Color

Background: Color of buttons and controls.

Foreground: Font and icon color for buttons and controls.

Title Text

Font

Font used for dialog titles.

Font Size

Font size for dialog titles.

General Text

Font

Font used for other text.

Font SIze

Font size for other text.

MessageBox Timeout

Sets how long certain dialogs stay open without user interaction. Default is 20 seconds.

List Item Height

Sets the height of list items in system dialogs.

Virtual Keyboard

The virtual keyboard in the iX App is affected by settings in the Multiple Languages function. For more details, see Set Up Multiple Languages. The following settings apply when using the default language.

Parameter

Description

Enable Virtual Keyboard

Enables the virtual keyboard.

Default Keyboard Layout

Select the default keyboard layout from the following options: Arabic, French, German, Hebrew, Italian, Korean, Russian, Simplified Chinese (Compact), Simplified Chinese, Spanish, Swedish, Traditional Chinese, US.

Keyboard Size Customization

Alpha Numeric Keyboard

Enable Keyboard Size Customization

Check this option to customize the size of the alphanumeric or numeric keyboard. Choose whether scaling is based on the Width or Height of the target resolution. Use the slider to set the keyboard size as a percentage of the target width or height.

Tip

Test the keyboard size by simulating the iX App before transferring it to the target device. For the most accurate scaling, ensure the PC's DPI settings are set to 100%.

Numeric Keyboard

The Project Ribbon Tab contains the following commands that enables building and simulation of the project. The table below highlights the differences between these commands:

Command

Validates the script code

Compiles the project

Deletes temporary files

Runs the iX App on the development PC

Communicates with the controller(s)

Build.png

Only changes are recompiled.

Rebuild.png

Entire project is recompiled.

Run.png

Simulate.png

Note

  • If project validation fails, check that the absolute path to the project, including its components, does not exceed 260 characters.

  • Projects must be stored on the local hard drive for iX Developer to be able to Run or Simulate them.

  • When launching the Build, Rebuild and Run commands iX Developer will automatically check for unused tags. This function can be disabled or enabled from CheckForUnusedTags in iX Developer Options.

Table 12. How to execute and quit each command

Command

Execute

Quit

Build.png

Click Build in the Project Ribbon Tab.

Press F6.

Rebuild.png

Click Rebuild in the Project Ribbon Tab.

Run.png

Click Run in the Project Ribbon Tab.

Press Alt + F4.

Click Run in the Quick Access Toolbar.

Press F5.

Press Alt + 4.

Simulate.png

Click Simulate in the Project Ribbon Tab.

Press Alt + F4.

Click Simulate in the Quick Access Toolbar.

Press Alt + 5.



Tip

For more information about the commands, see Run Group.

The iX Apps, projects, files and databases can be moved between devices using the following commands:

Compiles and transfers the iX App from the development PC to the HMI panel.

Fetches the project databases, app data, project files or source code from the HMI panel to the development PC.

Compiles and saves the iX App on the development PC, allowing it to be imported to an HMI panel later.

Imports the exported iX App to the HMI panel.

Fetches the entire iX project source code from the HMI panel to the development PC.

To transfer the iX App to the HMI panel, follow the steps below or watch the video tutorial.

Important

  • All files and databases on the target HMI panels will be overwritten.

  • To Fetch Source Code (Fetch From Target) later, enable Include source code when transferring project in Project > Settings > Project Transfer before the transfer.Fetch Source Code (Fetch From Target)

Video tutorial

Procedure. Instructions
  1. Connect the development PC and the HMI panel to the same network.

  2. In iX Developer, go to Project > Transfer > Transfer.

  3. Select a transfer mode:

    Test Mode

    Faster build time, slower runtime performance.

    Production Mode

    Slower build time, optimized runtime performance.

    Tip

    Use Test Mode during development. Use Production Mode for final deployment.

  4. In the Transfer Client, select the target HMI panel and click Transfer.

    Transfer.png
  5. Enter the credentials for the OS3 user Administrator or App Manager. For more information see User Management in the OS3 User Guide.

  6. Accept the Self-Signed Certificate if prompted (required the first time only).

  7. Click OK. Your authentication remains valid for 12 hours unless you close iX Developer. The lock symbol under Authenticated indicates if you are authenticated.

  8. The HMI panel stops the current iX App, installs the new iX App, and starts it automatically.

Note

Time zone, region or daylight saving settings will not be transferred if these settings have been changed manually on the HMI panel.

The Export feature compiles and saves the iX App on the development PC. This allows you to import it later to the HMI panel, see Import the iX App to the HMI Panel Using Transfer Client CLI for more details.

Important

To Fetch Source Code (Fetch From Target) later, enable Include source code when transferring project in Project > Settings > Project Transfer before the transfer.Fetch Source Code (Fetch From Target)

  1. In iX Developer, go to Project > Transfer > Export.

  2. Select a transfer mode:

    Test Mode

    Faster build time, slower runtime performance.

    Production Mode

    Slower build time, optimized runtime performance.

  3. Choose a destination for the exported project and click OK. A progress bar will indicate the export status.

Import the iX App to the HMI Panel

You can import an exported iX App in two ways:

Transfer Client (simple)

Use this method to manually import the iX App to one HMI panel. See instructions below.

Transfer Client CLI (advanced)

Use this method to import the iX App to multiple HMI panels or when manual import is not practical. See Import the iX App to the HMI Panel Using Transfer Client CLI.

Import the iX App to the HMI Panel Using the Transfer Client

Important

All files and databases on the target HMI panels will be overwritten.

. Prerequisites
  • Export the iX App beforehand using the Export command in iX Developer. For instructions, see Export the iX App.Transfer Terminology

Procedure. Instructions
  1. Connect the development PC and the HMI panel to the same network.

  2. On the development PC, navigate to the {Exported App}\TransferClient folder.

  3. Open X3TransferClient.exe.

  4. In the Transfer Client, select the target HMI panel and click Transfer.

  5. Enter the credentials for the OS3 user Administrator or App Manager. For more information see User Management in the OS3 User Guide.

  6. Accept the Self-Signed Certificate if prompted (required the first time only).

  7. Click OK. Your authentication remains valid for 12 hours unless you close iX Developer. The lock symbol under Authenticated indicates if you are authenticated.

  8. The HMI panel stops the current iX App, installs the new iX App, and starts it automatically.

Note

Time zone, region or daylight saving settings will not be transferred if these settings have been changed manually on the HMI panel.

The Fetch From Target command, located in the File menu, allows you to download the project source code from the HMI panel to the development PC.

Important

The Include source code when transferring project option must have been enabled in Project Properties > Project Transfer when the iX App was transferred to the HMI panel.

Tip

To reduce project size before fetching the project, first run the Clear Datalogger action, then run the Database Cleanup action. For more information on actions, see the Actions chapter.

Procedure. Instructions
  1. Click File > Fetch from Target.

  2. Follow the on-screen instructions to complete the process.

The transfer log tracks and displays the progress and details of data transfers between devices. Use the expand/collapse button in the Transfer Client to show or hide the log.

. Transfer log message color codes
  • Green: Success messages.

  • Red: Failure, error, or exception messages.

  • Black: General informational messages.

After a transfer completes, the log file is saved to: %temp%\Transfer Logs\

Each transfer creates one log file per device, named as follows: [TimeStamp]_[IPAddress]_[TargetType]_[TransferType].log

Note

If the iX App is transferred to an HMI panel and settings have changed since the last transfer, the previous log on the panel is replaced.

To create a backup of an iX Developer project, follow these steps:

  1. Go to File > Back Up Project, or Project > Back Up Project.

  2. Choose the location to save the ZIP file.

  3. Optional: Set a password to protect the ZIP file.

  4. Click OK to complete the backup.

To change the project target:

  1. Click Project > Settings to open the Project Properties.

  2. Select Display/Target.

  3. Choose the Target Type.

  4. (For PC targets only) Change the Screen Size if needed.

    Note

    Target rotate is not yet available for X3 HMI panels.

  5. Click OK.

  6. Select if you want to back up the project.

    Important

    Beijer Electronics strongly recommend to make a backup of the project before changing the project target.

  7. Click Convert.

  8. If the new screen size differs from the old target, you can then choose to automatically resize objects to fit the new screen. Resizing adjusts horizontal and vertical scales independently, optimizing for wide-screen targets. This may change the aspect ratio of objects.

    . Items resized automatically
    • Graphical objects

    • Popup screens

    • Font

    • Dynamics size and move settings

Limitations

  • Some objects and styles may not be compatible with the new target and will be deleted. A log of removed objects is displayed after the transformation and can be saved as a file.

  • Reverting to the previous target does not restore removed objects.