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1. About This Manual

This manual contains information on the software and hardware features of the Beijer Electronics
GL-9981 Programmable IO Module. It provides in-depth specifications, guidance on installation,
setup, and usage of the product.

1.1. Symbols Used in This Manual
This publication includes Warning, Caution, Note and Important icons where appropriate, to point out
safety-related, or other important information. The corresponding symbols should be interpreted as
follows:

WARNING
Indicates a potentially hazardous situation which, if not avoided, could result in
death or serious injury, and major damage to the product.

CAUTION
Indicates a potentially hazardous situation which, if not avoided, could result in
minor or moderate injury, and moderate damage to the product.

IMPORTANT
Highlights key information.

NOTE
Points out relevant facts and conditions.

TIP
Provides useful, non-essential information to assist you.

1.2. Modules Covered in This Manual

Module Type Other

GL-9981-
C-1

Programm
able IO

Open Linux (Debian), Docker support, CODESYS, OPC UA server, 16
GB (eMMC), 2 GB (DDR4), RJ-45, USB 2.0, max. 16 slices.

GL-9981-L Programm
able IO

Open Linux (Debian), Docker support, 16 GB (eMMC), 2 GB (DDR4),
RJ-45, USB 2.0.

About This Manual

Beijer Electronics, Doc ID: 53954 5 2025-09



2. Safety

Before using this product, please read this manual and other relevant manuals carefully. Pay full
attention to safety instructions!

In no event will Beijer Electronics be responsible or liable for damages resulting from the use of this
product.

The images, examples and diagrams in this manual are included for illustrative purposes. Because of
the many variables and requirements associated with any particular installation, Beijer Electronics
cannot take responsibility or liability for actual use based on the examples and diagrams.

2.1. Product Certifications
The product has the following product certifications.

2.2. General Safety Requirements

WARNING
• Do not assemble the products and wires with power connected to the system.

Doing so cause an "arc flash", which can result in unexpected dangerous events
(burns, fire, flying objects, blast pressure, sound blast, heat).

• Do not touch terminal blocks or IO modules when the system is running. Doing so
may cause electric shock, short circuit or malfunction of the device.

• Never let external metallic objects touch the product when the system is running.
Doing so may cause electric shock, short circuit or malfunction of the device.

• Do not place the product near inflammable material. Doing so may cause a fire.

• All wiring work should be performed by an electrical engineer.

• When handling the modules, ensure that all persons, the workplace and the
packing are well grounded. Avoid touching conductive components, the modules
contain electronic components that may be destroyed by electrostatic discharge.

CAUTION
• Never use the product in environments with temperature over 60℃. Avoid placing

the product in direct sunlight.

• Never use the product in environments with over 90% humidity.

• Always use the product in environments with pollution degree 1 or 2.

• Use standard cables for wiring.

Safety
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3. About the G-series System

System overview

• Network Adapter Module - The network adapter module forms the link between the field bus and
the field devices with the expansion modules. The connection to different field bus systems can be
established by each of the corresponding network adapter module, e.g., for MODBUS TCP, Ethernet
IP, EtherCAT, PROFINET, CC-Link IE Field, PROFIBUS, CANopen, DeviceNet, CC-Link, MODBUS/Serial
etc.

• Expansion Module - Expansion module types: Digital IO, Analog IO, and Special modules.

• Messaging - The system uses two types of messaging: Service messaging and IO messaging.

About the G-series System
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3.1. IO Process Data Mapping
An expansion module has three types of data: IO data, configuration parameter, and memory register.
The data exchange between the network adapter and the expansion modules is made via IO process
image data by internal protocol.

Data flow between network adapter (63 slots) and expansion modules

The input and output image data depend on the slot position and the data type of the expansion
slot. The ordering of input and output process image data is based on the expansion slot position.
Calculations for this arrangement are included in the manuals for network adapter and programmable
IO modules.

Valid parameter data depends on the modules in use. For example, analog modules have settings
of either 0-20 mA or 4-20 mA, and temperature modules have settings such as PT100, PT200, and
PT500. The documentation for each module provides a description of the parameter data.

About the G-series System

2025-09 8 Beijer Electronics, Doc ID: 53954



4. Specifications

4.1. Enviromental Specifications

Operating temperature -20°C - 50°C

Relative humidity 5% - 90% non-condensing

Mounting DIN rail

Shock operating IEC 60068-2-27 (15G)

Vibration resistance IEC 60068-2-6 (4 g)

Industrial emissions EN 61000-6-4: 2019

Industrial immunity EN 61000-6-2: 2019

Installation position Vertical and horizontal

Product certifications CE, UKCA

CAUTION
Always read the Hardware Setup chapter before installing the module.

4.2. General Specifications

UL system power Supply voltage: 24 VDC nominal, Class 2

System power* Supply voltage: 24 VDC nominal

Supply voltage range: 15 - 28.8 VDC

Reverse polarity protection

Power dissipation 225 mA typical @ 24 VDC

Current for IO module** 0.5 A @ 5 VDC

Isolation System power to internal logic: Non-isolation

System power IO driver: Isolation

UL field power Supply voltage: 24 VDC nominal, Class2

Field power Supply voltage: 24 VDC typical (Max. 28.8 VDC)

Field power range is different depending on IO module
series. See the module user manual.

Max. current field power contact DC 8 A

Wiring 0.05 mm² - 1.31 mm² (30-16 AWG)

Weight 87 g

Module size 22.5 mm x 109 mm x 70 mm

* Since the product does not include UPS, removing the power before soft shutdown can cause
data damage. Make sure it has been shut down normally and then disconnect the power.

** If the load used exceeds the specifications, a throttling mode may occur due to heat, resulting
in degraded performance or abnormal operation. The internal temperature must be less than
85°C.

Specifications
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4.3. Interface Specifications

PIO Type Embedded type programmable IO

Module versions GL-9981-L: Linux version

GL-9981-C-1: CODESYS version

CPU ARM Cortex-A72 @ 1 GHz

OS Linux Debian

RAM LPDDR4 2 GB

eMMC flash memory 16 GB

Interface connectors RJ-45 socket x 1

USB 2.0 port x 2

Monitor port x 1

Ethernet baud rate 100 Mbps, Auto-negotiation, Full duplex

LED Indicators Module status (MOD) - Green

Network status (NET) - Green

Custom (RUN) - Green/Red

Expansion IO module status (IOS) - Green/Red

RTC Retain time: < 15 day/accuracy, < 2 min/month.

Status: Fully recharged battery at room temperature.

For more information, refer to the chapter Battery Charging below.

4.3.1. Battery Charging
Recommend charging when the battery is discharged is 16 hours.

Battery charging time Retain time (room temperature)

4 hours > 2 days

12 hours > 12 days

16 hours > 15 days

Operating problems when the battery is discharged

• Retain data is not saved.

• RTC data is not stored and is the initial value.

• Reset button does not work (PLC Reset and Factory Reset cannot be used).

4.4. GL-9981-L Specifications

Programming environment C/C++ (on Linux)

4.5. GL-9981-C-1 Specifications
All GL-9981-C modules includes specific CODESYS capabilities based on the installed CODESYS
Application-Based Runtime License. For instance, GL-9981-C-1 has the Control Basic L license. For
further details about the CODESYS Application-Based Runtime License, refer to the CODESYS website.

Specifications
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Programming environment CODESYS 3.5 SP19 Patch 4

Code size 3 MB

Available I/O channels 256

Fieldbuses Modbus TCP, 2 instances

Communication OPC UA server, max. 512 tags

Visualization Web Visualization, max. 128 tags

Specifications
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5. Connectors and Ports

This section describes the modules connectors and ports.

5.1. Wiring Diagram

Pin no. Signal description

1 System power, 24 V

2 System power, ground

3 Frame ground

4 Field power, ground

5 Field power, 24 V

WARNING
Never connect system power to field power! Use separate power supplies.

5.2. RJ-45 Socket
For information on network installation, refer to Network Installation.

Connectors and Ports
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RJ-45 Signal name Description

1 TD+ Transmit +

2 TD- Transmit -

3 RD+ Receive +

4 - -

5 - -

6 RD- Receive -

7 - -

8 - -

Case Shield Shield

5.3. USB 2.0 Port

USB 2.0 (Type-A) Signal name Description

1 VCC +5 VDC

2 D- Data-

3 D+ Data+

4 GND Ground

NOTE
250 mA continuous current per channel.

5.4. Monitor Port

Monitor Signal Name Description

1 TMDS Data2+ TMDS Lanes

2 TMDS Data2 Shield

Connectors and Ports
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Monitor Signal Name Description

3 TMDS Data2-

4 TMDS Data1+

5 TMDS Data1 Shield

6 TMDS Data1-

7 TMDS Data0+

8 TMDS Data0 Shield

9 TMDS Data0-

10 TMDS Clock+

11 TMDS Clock Shield

12 TMDS Clock-

13 CEC CEC Remote Control

14 Reserved

15 SCL DDC Clock

16 SDA DDC Data

17 GND CEC/DDC/HEAC Ground

18 +5V Power EDID/DDC

19 HPD Hot Plug Detect

Connectors and Ports
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6. Buttons and Switches

This section describes the buttons and switches on the module.

6.1. Button

Push button Signal name Description

Push and detach User-defined Operates according to the user's program.

6.2. Toggle Switch

Switch position Module status Description

Down Stop PLC in stop mode

Up Run PLC in run mode

6.3. DIP Switch

Dip switch Signal name Description

Pin 1 ON Force USB boot mode After connecting to PC and booting in USB Device
mode, OS installation is possible.

Pin 2 ON EEPROM write protect Protects the onboard EEPROM that stores the boot
code.

WARNING
Turn off the DIP switch when the module is not in use.

Buttons and Switches
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7. LED Indicator

LED Function Color

MOD Module status Green

NET Network status Green

RUN Run/Stop status or Custom LED Green/Red

IOS Expansion module status Green/Red

7.1. MOD (Module Status)

Status LED indication Description

Not powered Off Power is not supplied to the module.

Idle Off Module is operating normally, not accessing eMMC.

Operational Flashing green
(irregular, at
bootup)

Module is operating normally, accessing eMMC.

Boot error
detected

Flashing green
(regular
pattern, at
bootup)

Error during booting. See Error patterns below.

Error patterns

Long flashes Short flashes Status

0 3 Generic failure to boot

0 4 start*.elf not found

0 7 Kernel image not found

0 8 SDRAM failure

0 9 Insufficient SDRAM

0 10 HALT state

2 1 Partition not FAT

2 2 Failed to read from partition

2 3 Extended partition not FAT

2 4 File signature/hash mismatch

3 1 SPI EEPROM error

3 2 SPI EEPROM is write-protected

LED Indicator
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Long flashes Short flashes Status

3 3 I2C error

4 4 Unsupported board type

4 5 Fatal firmware error

4 6 Power failure type A

4 7 Power failure type B

7.2. NET (Network Status)

Status LED indication Description

Not powered Off No power supplied to the unit.

Ethernet off Off LAN cable is not connected, or Ethernet is inactive.

Ethernet activity Green LAN cable is connected and Ethernet is active.

7.3. RUN
The RUN LED has different functions depending on the model.

7.3.1. Run/Stop Status (GL-9981-C)
For model GL-9981-C, RUN shows the operating state of the PLC program (CODESYS).

Status LED indication Description

Run Green The PLC program is running.

Stop Off The PLC program is stopped.

NOTE
If the PLC program is deleted while running, the LED remains in its last state.

7.3.2. Custom LED (GL-9981-L)
For model GL-9981-L, RUN is controlled using the provided library.

7.4. IOS (Expansion Module Status)

Status LED
indication

Description

No expansion I/O Off No expansion modules are connected or the device is
not powered.

Expansion I/O active Green Expansion modules are connected.

LED Indicator
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Status LED
indication

Description

Configuration fault Red One of the following errors occurred:

• Invalid expansion module ID detected

• Initial protocol failure

• Vendor code mismatch between adapter and
expansion module

• Expansion module configuration changed

• Too many expansion modules

• Communication failure

• I/O size overflow

LED Indicator
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8. Hardware Setup

CAUTION
Always read this section before installing the module!

CAUTION
Hot surface! The surface of the housing can become hot during operation. If the
module is used in high ambient temperatures, always let it cool down before
touching it.

CAUTION
Working on energized devices can damage the equipment! Always turn off the power
supply before working on the module.

8.1. Enviromental Requirements
Installation

• Read the Enviromental Specifications carefully!

• Choose a well-ventilated area.

• Avoid enclosed spaces.

• Use a circulation fan to improve airflow, if possible.

Temperature Guidelines

• If the ambient temperature reaches 50°C or higher, the CPU clock frequency will be 600 MHz.

• To operate at 55°C or higher, install a fan outside the module.

Monitoring and Actions

• Operating temperature may vary based on environmental conditions.

• After installation, monitor the CPU temperature based on the application.

• Take appropriate actions if the CPU temperature exceeds 85°C.

Hardware Setup
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8.2. Space Requirements
The following drawings show the space requirements when installing the G-series modules. The
spacing creates space for ventilation, and prevents conducted electromagnetic interference from
influencing the operation. Installation position is valid vertical and horizontal. The drawings are
illustrative and may be out of proportion.

CAUTION
Not following the space requirements may result in damaging the product.

Hardware Setup
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8.3. Mount Module to DIN Rail
The following chapters describe how to mount the module to the DIN rail.

CAUTION
The module must be fixed to the DIN rail with the locking levers.

8.3.1. Mount GL-9XXX or GT-XXXX Module
The following instructions apply to these module types:

• GL-9XXX

• GT-1XXX

• GT-2XXX

• GT-3XXX

• GT-4XXX

• GT-5XXX

• GT-7XXX

GN-9XXX modules have three locking levers, one at the bottom and two on the side. For mounting
instructions, refer to Mount GN-9XXX Module.

Mount to DIN rail

Dismount from DIN rail

Hardware Setup
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8.3.2. Mount GN-9XXX Module
To mount or dismount a network adapter or programmable IO module with the product name
GN-9XXX, for example GN-9251 or GN-9371, see the following instructions:

Mount to DIN rail

Dismount from DIN rail

Hardware Setup
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8.4. Mount Removable Terminal Block
To mount or dismount a removable terminal block (RTB), see the instructions below.

Mount a removable terminal block

Dismount a removable terminal block

Hardware Setup
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8.5. Connect Cables to Removable Terminal Block
To connect/disconnect cables to/from the removable terminal block (RTB), see the instructions
below.

WARNING
Always use the recommended supply voltage and frequency to prevent damage to
the equipment and ensure optimal performance.

Connect cable

Disconnect cable

Hardware Setup
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9. How to Start the Module

1. Turn on the power to boot up the device.

2. After booting is complete, the BUS Scan process program is automatically executed. When the
scan is completed, the IOS LED turns green.

How to Start the Module
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10. IP Settings

IP address 192.168.100.72

Subnet mask 255.255.255.0

Router 192.168.100.1

IP Settings
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11. Configuration Diagrams

11.1. Programming Configuration Diagram
Internal process creates shared memory.

Internal processes and user programs share shared memory using semaphores.

CAUTION
If any user program is executed earlier than Bus Scan Process, it will not operate
normally.

• Bus Scan Process (pibus.service) is automatically executed using SYSTEMD.

• File location of pibus.service: /lib/systemd/system/pibus.service.

• Location of actual executable file: /home/crevis/pibus/M_PibusScan.

• Only one of the Linux Process or CODESYS process should be running (Cannot run
concurrently).

Configuration Diagrams
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11.2. System Configuration Diagram

Configuration Diagrams
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12. CODESYS

This section describes how to use the CODESYS integrated development environment.

TIP
Download the correct CODESYS IDE version for your target device from SmartStore.
See Specifications for details.

12.1. Download CODESYS Template Project
A CODESYS template project file is available on the Beijer Electronics website. This file contains a
complete project with all necessary files for an easy startup. Follow these steps to download and
open the template:

1. Download the template file from the Beijer Electronics Website.

2. In CODESYS, go to File > Project archive > Extract archive.

3. Select the template file and extract it.

12.2. Create a New CODESYS Project
1. Open CODESYS.

2. Optional: Install device description
Instead of using the Standard project template (see Download CODESYS Template Project) in
the instructions below, you can use the device description (XML). To install this, go to Tools >
Device Repository > Install, and install the required XML files for your application.

3. Click File > New Project.
4. Select Standard project, and click OK.

5. Configure the following settings:

• Device: Beijer GL-9981x MC SL (Beijer Electronics)

• PLC_PRG in: Structured Text (ST)

6. Click OK.

7. Right-click on an empty space in the rack and select Plug Device.

CODESYS
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8. Choose a module from the list and click Plug Device.

9. Double-click Device, then select Scan network.

10. Select the desired device from the scanned devices and click OK.

11. Click Yes to activate user management on the device.

12. Enter the login credentials and click OK.

13. Write a test program and click Login in the top bar.

14. Click Start in the top bar to run the program.

CODESYS
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12.3. Example: Activate CODESYS License
Use the License Manager in CODESYS to manage licenses for add-on products on a CODESYS device.
These steps apply only when modifying or adding to an existing CODESYS license. In the following
example a license is activated on a soft container device (Raspberry Pi).

1. Click Tools > License Manager.
2. Select Device, and click Next.
3. Select Soft container, and click Next.
4. Select the scanned Raspberry Pi, and click OK.

5. Enter login credentials and click OK.

6. Click Install Licenses.
7. Select Activate license, then click Next.
8. Enter the Ticket ID, and click Next to complete the installation.

12.4. Add a Module XML to CODESYS
1. Click Tools > Device Repository.

2. Select the module XML, and click Open.

3. After installation, the device will appear in the overview.

CODESYS
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12.5. I/O Control Functions in CODESYS Project Example

Folders

DataTypeDef Data type definitions.

Function Functions used for I/O control.

global Global variable.

MainProgram Example program for function testing.

Struct Definitions for structures used in the internal bus.

12.5.1. I/O Control Functions
The following functions are available in the Function folder.

Pibus Control (pibus_Control)

pibusInit Initialize semaphores and shared memory. Confirm that the internal
bus is running before proceeding.

VAR_INPUT - None

VAR_OUTPUT - Execution result

Read_InputImage Read values from the input image.

VAR_INPUT - Addr (starting address), pBuffer (buffer), Len (length)

VAR_OUTPUT - Execution result

Read_OutputImage Read values from the output image.

VAR_INPUT - Addr (starting address), pBuffer (buffer), Len (length)

VAR_OUTPUT - Execution result

Write_OutputImage Write values to the output image.

VAR_INPUT - Addr (starting address), pBuffer (buffer), Len (length)

VAR_OUTPUT - Execution result

Read_Slot (Input
module only)

Read the value of the specified slot.

VAR_INPUT - Slot (slot number), pBuffer (buffer)

VAR_OUTPUT - Execution result

Write_Slot (Output
module only)

Write the value to the specified slot.

VAR_INPUT - Slot (slot number), pBuffer (buffer)

VAR_OUTPUT - Execution result

Get_Prm Read the parameters of the specified slot.

VAR_INPUT - Slot (slot number), pBuffer (buffer)

VAR_OUTPUT - Execution result

Set_Prm Write the parameters to the specified slot.

VAR_INPUT - Slot (slot number), pBuffer (buffer)

VAR_OUTPUT - Execution result

CODESYS
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Semaphore Control (sem_Control)

semInit Initialize the semaphore.

VAR_OUTPUT - Execution result

semEnter Use the semaphore.

semLeave Release the semaphore.

Shared Memory Control (shm_Control)

shmInit Initialize shared memory.

VAR_OUTPUT - Execution result

shmRead_X Read shared memory to a buffer.

VAR_OUTPUT - Execution result

shmWrite_X Write buffer data to shared memory.

VAR_OUTPUT - Execution result

12.5.2. Function Test Example
This example demonstrates manually selecting and executing a test after initialization.

Example

• init: If initialization is successful, the init variable is set to 255. Testing is only possible when
initialization is completed successfully.

• test_selet: Select the desired test with the test_selet variable.

• test_time: Once the test is executed, the test_time variable is set to 1 to prevent repetition of the
test.

• slot: Set variable for the slot number.

• io_rw_byte: The value to be written is stored in advance in the io_rw_byte buffer.

• addr: Set variable for the starting address.

• len: Set variable for the length.

TIP
Refer to the Pibus_GL9981_Sample project for the complete program example.

CODESYS
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12.6. Add the Persistence Manager
The Persistence Manager is a standard component of the Application Composer. It manages
persistent remanent data by recognizing specific attributes in variable declarations. For more details,
visit the CODESYS website.

1. In CODESYS, click View > Modules.
2. Click Add module library.

3. Select AC_Persistence and click OK.

4. Right click on project name and select Add Top-Level Module Instance.

5. Select PersistenceManager and click Add Module.

CODESYS
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6. Right click on Channels and select Add SubModule Instance.

7. Choose PersistantChannel and click Add Module.

8. Right click Data Storage and select Add SubModule Instance.

9. Choose one of the following storage formats, then click Add Module:

• ASCIIFileStorage - Saves the values in ASCII format in a file. The ASCIIFileStorage format
allows to open the archive file in a text editor and to modify the values. Comments can be
added to ASCII file archive. These will be ignored when the file is read.

• BinaryFileStorage - Saves the values in binary format in a file.

• BinaryMemoryStorage - Saves the values in binary format to the RETAIN area of the compiler,
or the device concerned, for example, to the NVRAM of the device.

10. Click on PersistenceChannel and select Parameters.
11. Ensure that the xReadVarsDuringInit parameter is set to FALSE.

• If TRUE, persistent variables are loaded during initialization.

• If FALSE, they are loaded during the first application cycle.

12. Click Generate the project from the module tree.

13. CODESYS generates new function blocks and tasks for persistence handling.

14. In the Global variable list or POU, add an attribute before the tags that need to be persistent.
All attributes have a reference to the file for the tags, marked in bold in the example below.

Example

PROGRAM PLC_PRG
VAR
            {attribute 'ac_persist' := 'PersistenceChannel1'}
            iMyInt: INT;                         //This variable is persistant
            wMyWord: WORD;                       //This tag is NOT persistant
END_VAR
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13. System Setup (GL-9981-L)

This chapter describes how to set up the GL-9981-L (Linux version). It covers operating system
installation, Docker and WebIQ setup, CODESYS Runtime installation, and I/O control using C
language.

13.1. Install the OS
Follow the steps below to install the OS.

1. On the dip switch (SW), set Pin 1 to ON.

2. Connect the module to the PC with USB.
Cables

• GL-9981-X-X: USB A(M) to A(M) cable

• GL-9982-X-X: USB C(M) to A(M) cable

NOTE
Ensure that the cables are authentic and that all data lines are properly
connected.

3. Connect the module to the 24 VDC system power.

4. Use rpi-boot program to recognize Raspberry Pi as a USB device.

TIP
Download rpi-boot from the Raspberry Pi website.
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5. If the OS is intended to be saved as an image file, proceed to step 6, If not, follow these
instructions:

a. Download and install SD Formatter from the SD Association website.

b. Open SD Formatter.

c. Choose Drive.

d. Click Option, select FORMAT TYPE - FULL, and click Format to format the drive.

6. Download and install Win32 Disk Imager from the Win32 Disk Imager website.

7. Open Win32 Disk Imager.

1. Select OS Image file.

2. Select Device.

3. Click Write. To save the OS in the module as an image file, click Read.
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13.2. Install Docker
Prerequisites

• The hardware must be connected to the internet during the whole process. All dependencies and
installation files are downloaded during this session from the Docker hub.

Instructions

1. Open a console (e.g. Comand Prompt or Windows PowerShell).

2. Connect to the module with SSH:

ssh beijer@192.168.100.72

Default IP 192.168.100.72

Username beijer

Password Jzy!q7

3. Change the IP address:

a. Open the configuration file in nano:

nano /etc/dhcpcd.conf

b. In the interface eth0 section, enter your own IP address and router (gateway) address.
Example: 192.168.1.210 (IP) and 192.168.1.1 (router).

c. Press CTRL+X to exit.

d. Press Y to confirm.
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e. Press Enter to save.

f. Reboot the hardware:

sudo reboot

4. Run the following command to uninstall old or conflicting packages:

for pkg in docker.io docker-doc docker-compose podman-docker containerd runc; do sudo apt-get remove $pkg; done

5. Set up Dockers repository:

a. Add Docker's official GPG key:

sudo apt-get update
sudo apt-get install ca-certificates curl
sudo install -m 0755 -d /etc/apt/keyrings
sudo curl -fsSL https://download.docker.com/linux/raspbian/gpg -o/etc/apt/keyrings/docker.asc
sudo chmod a+r /etc/apt/keyrings/docker.asc

b. Set up Docker's APT repository:

echo \
  "deb [arch=$(dpkg --print-architecture) signed-by=/etc/apt/keyrings/docker.asc] https://download.docker.com/linux/raspbian \
  $(. /etc/os-release && echo "$VERSION_CODENAME") stable" | \ 
  sudo tee /etc/apt/sources.list.d/docker.list > /dev/null 
sudo apt-get update

6. Install the latest Docker version:

sudo apt-get install docker-ce docker-ce-cli containerd.io docker-buildx-plugin docker-compose-plugin
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7. Press Y to confirm.

8. To test the Docker engine, run the Docker test container:

sudo docker run hello-world

If successful, Docker is installed and running.

13.2.1. Install the WebIQ Docker Container
Prerequisites

• Install and verify the Docker engine before you install the WebIQ Docker container. See Install
Docker.

• The hardware must be connected to the internet during the whole process. All dependencies and
installation files are downloaded during this session from the Docker hub.

Instructions

1. Open a console (e.g. Comand Prompt or Windows PowerShell).

System Setup (GL-9981-L)

2025-09 40 Beijer Electronics, Doc ID: 53954



2. Connect to the module with SSH:

ssh beijer@192.168.100.72

Default IP 192.168.100.72

Username beijer

Password Jzy!q7

3. If you use a prototype, disable port 10123 to avoid conflicts:

a. Log in to the WebIQ portal with <IP:10123>.

b. Create a user and a password.

c. Go to Settings > LISTEN PORT.

c. Deactivate port 10123 and confirm.

4. Download WebIQ Server App from Beijer Electronics Smart Store.

5. Change the file extension from .bapp to .zip.
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Example: webiq-2.16.3.zip.

6. Extract the ZIP file.

7. Open the app folder.

8. Copy compose.yaml to a USB drive.

9. Insert the USB drive in USB 1 (top port) on the GL-998X.

10. To verify the operating system, run:

Uname -a

NOTE
This step is not required from WebIQ version 2.16.4, since containers are
available in all supported formats.

11. Read the status and names of connected drives:

sudo fdisk -l
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12. Create a mount folder (example: USB1):

sudo mkdir /media/USB1

13. Mount the USB drive:

sudo mount /dev/sdb1 /media/USB1/

14. Install the WebIQ server from the USB drive:

sudo docker compose -f /media/USB1/compose.yaml up -d

15. Verify the Docker installation:

sudo docker ps

16. Check Docker status for all installed containers:

sudo docker stats

17. Install the runtime licenses.
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13.3. Install CODESYS Runtime
Follow these steps to install CODESYS Runtime on a Raspberry Pi.

1. Open CODESYS on the PC that will connect to the Raspberry Pi.

2. Click Tools > CODESYS Installer.
3. In the AddOns section, click Browse. .

4. In the search field, enter raspberry.

5. Select CODESYS Control for Raspberry Pi, choose version, and click Install.

6. Accept the license agreement and click Continue.

7. Close CODESYS and click OK.

8. Restart CODESYS and click Tools > Update Raspberry Pi.
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9. Enter the login credentials and the IP address of the target device. The Raspberry Pi and the PC
must be on the same subnet.

Default credentials and IP

Username beijer

Password Jzy!q7

IP Address 192.168.100.72

10. Select the installed CODESYS Runtime Package version, then click Install.
11. Select Multicore, then click OK.

12. Click System Info to verify the installation in the Package Info section.

13.4. Delete CODESYS Runtime
Follow these steps to remove CODESYS Runtime from the Raspberry Pi:

1. Run CODESYS and click Tools > Update Raspberry Pi.
2. Enter the login credentials and the IP address of the target device. The Raspberry Pi and the PC

must be on the same subnet.

Default credentials and IP

Username beijer

Password Jzy!q7

IP Address 192.168.100.72
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3. Select the installed CODESYS Runtime Package version.

4. Click Remove to uninstall the CODESYS Runtime.

13.5. Login Credentials

Username beijer

Password Jzy!q7

Root Password 43dZM#hQDM

13.6. Controll I/O with C Language
The following files are used to control I/O in C Language for the module:

Location of the files

• /home/crevis/GL-9981-example_rev100

FIles and their functions

• PibusIoTest.c: Example program to test the module, including operation examples for RTC, LED,
SW, and I/O.

• PibusIoTest.h: Contains definitions of pointers and global variables used for I/O control.

• PibusStruct.h: Defines structures used in the internal bus.

TROUBLESHOOTING
If the program does not close properly, restart the device.

13.7. Functions Used in PibusIoTest.c

Function Description

int pibusInit(void) Initialize the internal bus

• Initialize the semaphore to use

• Initialize shared memory

Return(-1) - Initialization failed

int Read_InputImage(u16 Addr, u8*
pBuffer, u16 Len)

Read values from input image

• addr - starting address / pBuffer - use buffer / Len -
length

• Return(-1) - Abnormal Addr and Len values

int Read_OutputImage(u16 Addr,
u8* pBuffer, u16 Len)

Read values from output image

• addr - starting address / pBuffer - use buffer / Len -
length

• Return(-1) - Abnormal Addr and Len values

int Write_OutputImage(u16 Addr,
u8* pBuffer, u16 Len)

Write values from output image

• addr - starting address / pBuffer - use buffer / Len -
length

• Return(-1) - Abnormal Addr and Len values
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Function Description

void Read_Slot(u8 slot, u8* pBuffer)
(Input module only)

Read the value of the slot

• slot - slot number / pBuffer - use buffer

void Write_Slot(u8 slot, u8* pBuffer)
(Output module only)

Writes the value of the slot

• slot - slot number / pBuffer - use buffer

void Get_Prm(u8 slot, u8* pBuffer) Read the parameters of the slot

• slot - slot number / pBuffer - use buffer

void Set_Prm(u8 slot, u8* pBuffer) Write the parameters of the slot

• slot - slot number / pBuffer - use buffer

void Get_Rtc(u8* pBuffer) Get the time stored in the RTC

• pBuffer - use buffer

void Set_Rtc(void) Store system time in RTC.

void Read_Sw_push(u8* pBuffer) Read the state value of SW(Push)

• pBuffer - use buffer

void Read_Sw_toggle(u8* pBuffer) Read the state value of SW(Toggle)

• pBuffer - use buffer

void Read_Led(u8* pBuffer) Read the state value of the LED

• pBuffer - use buffer

void Write_Led(u8* pBuffer) Change the state of the LED

• pBuffer - use buffer

• 0: off, 1: Green, 2: Red

13.8. Compile PibusIoTest.c in the Terminal
You can compile the PibusIoTest.c example directly in the Raspberry Pi terminal using the following
command:

crevis@raspberrypi:~/GL-9981-example_rev100 $ gcc -o PibusIoTest PibusIoTest.c -lpthread -lrt

Example: Reading and Writing Connected I/O

When you run the compiled program, it displays the connected I/O modules, their input and output
values, and parameter data.

Sample output:

*********************** IO TEST ***********************

[1] GT-1238  
In: ff  
Out:  
Get Prm: 55 aa  

======================================================

[2] GT-2628  
In:  
Out: ff  
Get Prm: 00 00  
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======================================================

[3] GT-2764  
In:  
Out: ff  
Get Prm: 05 05  

======================================================

[4] GT-3118  
In: ff 0f ff 0f fd 0f ff 0f ff 0f ff 0f ff 0f ff 0f  
Out:  
Get Prm: ff aa 00 00 00 00 00 00 00 9a  

======================================================

[5] GT-4118  
In:  
Out: ff 0f ff 0f ff 0f ff 0f ff 0f ff 0f ff 0f ff 0f  
Get Prm: 00 00 00 00  

======================================================

[6] GT-2764  
In:  
Out: ff  
Get Prm: 00 02  

======================================================

[7] GT-22ba  
In:  
Out: ff ff ff ff  
Get Prm: 00 00 00 00 00 00 00 00  

======================================================

13.9. Use the Geany Editor on Raspberry Pi
Follow these steps to use the Geany editor on a Raspberry Pi.

1. Connect a monitor, mouse, and keyboard to the Raspberry Pi.

2. Turn on the power and wait for the system to boot.

3. Click Programming > Geany Programmer`s Editor.
4. Click Build > Set Build Commands.
5. Add -lpthread -lrt at the end of the build command.
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6. Open the example program.

7. Click the Build icon to compile the program.

8. Once the build is complete, an executable file is created, and a confirmation message appears.
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